4.16 Atlas Bugs and Issues


Next time trust me and NEVER PG :joy::joy:


Lol :joy::joy::joy: I’ll do that.


Drop your shield in the fort - then you can kill him.


Once again dear,

PvP is disabled. Not because of the shield, it’s just disabled. So even if u drop the shield, it’s disabled, if u go to red zone, it’s still disabled. If all ur castles are blocked by lvl 100 player who don’t know shit about atlas, u still cannot kill them because



Oh I assumed that was PGs way of saying the PvP shields were up. :woman_shrugging:


I wish they used common sense! Sigh :pensive:


I do totally agree with you.


Just a small thing but in the tally for troops owned it isn’t counting barracks troops so is this going to be what happens when they hand out the glory per troops? Or is it going to go with the barracks totals as well. This is showing what’s on prims currently


Can’t see all infrastructure on an iPhone 8+ either

So how am I supposed to transfer troops?



Add this in

  • Rider missions stops you from using the dragon
  • that is the biggest f*up in the history. Per definition your strongest dragonriders are on your strongest dragons - its ludicrous to lock them out for 12h.
  • it costs 1200 rubies or more to speedup a rider, which gives 8 scrolls as a reward


This does also apply to iPhone X and is MAJOR issue as this results in not being able to use the barracks which is quite important now as it holds all your troops! Please fix this ASAP before Tuesday with the Bubbles going down…! @pgEcho @PGDave


You can still transfer to primarch by tapping on the primarch and its troops transfer button. Workaround until scrolling is fixed.

Issues with atlas update

Also can we chose to cancel with no reward. Even if it cost something. If my team gets attacked in the middle of a mission. I would like the option to call me rider back for help.


Attacks are disabled. I tried and got message that we can’t attack until after PvP ends. Tried dropping both bubbles and got the same.



it sucks we got a former teammate on castle and she has no atlas anymore we cant use the bank now there


Here is the issue I see, @PGDave and @pgEcho . Right now Atlas is set up where lots of obstacles block your path from just playing the game:

You want to go somewhere? Well…only two teams can have free passage so you move faster but you can go nowhere.

You want to attack? Haha, cant do that. It will cost you dearly later based on the way Team Troops are set up.

Atlas Missions, you want to do those? You now cannot use that dragon for 12 hours.

At some point the game is almost insisting you don’t play it and you now what, at some point I am going to just agree with what the game wants and stop playing.


hummmm, so it also seems that if you have an enemy prim at your land, doesn’t matter where they are…Mine, Castle, Poacher…they are blocking the whole land. Not just that one castle/Mine like before but the whole land and all the castles, mine, poachers in that land. Cant mine gold, cant transfer gold or rss to any castle, cant use team portal. please don’t tell me this is intentional. :sob::sob::sob::sob:


Atlas rider quests are not well designed.

  1. Too long. Cut them down to 1/4 or 1/2 the time. The lower level quests with lower payouts should take less time than the level 5 quests.
  2. Why the element attached to the quest!? This makes no sense… not everyone even has a rider with every element. This is silly and just obstructs any ability to do the quest you want. Get rid of it.
  3. Rider level is just way unbalanced. Grogg with his full season gear is level 2. Level is heavily weighted towards high level gear, meaning lower level quests for most people. 12 hours for 75 egg tokens is not ever going to be worth it.

Please make these more useful.


Sounds like an upgrade