A breeding question


If you mean research hall and not forge you can still click it. I can’t do sapphire research until hall research hall lvl 7 but can still click the 0/15 eggs to get to the castle


Went ahead and tried it on 2 other accounts (main is done with research, or at least what I felt was worth doing).

This one isn’t being candid. Nothing happens when the eggs are clicked. Other account doesn’t have any spare eggs and it seems to be working, and the one that does is. Perhaps I should have tried it elsewhere first but excuse me if the accounts I’m on the most were ineligible/not providing any pop-up whatsoever. I’d assumed from looking at those two that whatever the cause may be, it doesn’t always work so took to suggesting to OP that they should try it first before upgrading breeding castle on a whim.
Yes @CheekyGrinch that’s what I meant.


Did you actually click on any gold, platinum or sapphire research options?

Even if you don’t have the right research hall level to do a particular piece of research, you can still click into it, click the egg requirement and get to breeding castle. Maybe if you actually tried what I said instead of assuming?


I think Ebony is joking around


God I hope so.


Ok lemme try grumpybigbird


That handwriting is so neat!


Damn near identical…


Nice handwriting haha

Kirin on the perch I discern!


It’s a shame how long I’ve been playing and I never knew that


Kirin is my bitch lol she does what i want, when i want.

Got T-hor perched with her, few hundred sigils for a clean rider to perch is ok by me.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.