Android - Atlas


#1

@PGDave this is how the Beta Map currently looks on my Samsung Galaxy S8.
Everything is glitchy at the Moment. After each click on a Goldmine, Poacher or Island the game screen freezes up for like 30sec and turns black. Same for moving around the Map.

Has someone else with Android complained about it? Or can u Guys investigate it please?
I totally love Beta. But cant to anything so far.

Screenshot_20171018-141903

Screenshot_20171018-141919

Screenshot_20171018-142731


#2

Mines exactly the same … also a pain that you need to download a update … then download extra each time you load atlas attack a poacher or gold mine


#3

Zooming is pretty slow for everyone, but it sounds like the S8 is especially affected. Our lead 3D engineer is aware of several specific sources of slowness and is working on them. We suspect there are other contributing factors we don’t know about yet, and it’s going to take some iteration to get everything buttery smooth. But It think we can get it to a playable state sooner. Certainly no later than the 3.80 release a little less than a month … but I’m also trying to figure out what we can do to get some of these improvements out sooner (there’s a mini-release next week, but that might be too soon to test thoroughly as we have to submit ASAP to release anything next week due to vagaries of the app store).

Thanks for your detailed report.

EDIT: Update from our lead 3D engineer after reviewing this: “I have a theory on what could be causing this; there are some bugs with the unit path rendering on some samsung devices. We may want to consider just turning that off for android for 3.71 as a short-term workaround.”


#4

Hey @PGDave . I’m sure you will fix that in time

Wanted to let u know that i cleaned App Cache and deleted WD and reinstalled it. Took a while to reload all Content but zoom works now pretty good as he did in the past version, works smoothly and the black screen isnt here anymore if i click islands or mines. Only the loading times at Islands “Manage” are a bit long.

I think maybe some “old data” in the App’s cache slowed down beta for me so far.

Right now i can attack invader on mines and poachers without any Issue and moving around the Map aswell. Moving works better as it was in the older Atlas Version.

Maybe i solved this Problem for now by just reinstalling the Game and load all of the Content again.

Ps.: Only the Graphic’s from Islands and all Primarchs on the Map is still messed up, but i can live with that

Regards, Suma


#5

Whoa @Sumatan, I wouldn’t have guessed that would’ve had such a dramatic impact. I’m glad to hear it though! I’ve let @PGEggToken know too so he can ask other players to try it out too if they write in with similar problems.

Also, some good news – our lead 3D engineer has pushed some serious performance optimizations into our build that we’re submitting today and releasing next week. They’re a bit risky, but we’re going to test it all day and as long as nothing serious is discovered these first batch of improvements should be live in less than a week (!).


#6

Thanks for letting me know…!

Hope the new Performance Optimizations wont force me to reinstall again. Lmao.

Thank you aswell for letting @PGEggToken know. Maybe it helps the smaller Amount of Android users in WD to play Atlas smoother :slight_smile:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.