Android vs Wifi

I am facing an issue from the beginning of playing this game ( around 2 years ) , I had many android and iOS devices to test this

, when ever I connects the game with wifi on iOS , it’s working fine , but an android, it’s says network error , I tested this in different android devices and different wifi internet connections , but facing same issues , but for iOS on same wifi all good ,
If I use mobile network or wifi with vpn , it’s working fine on android too ,

Anyone facing similar issues ? Any solutions?

Note: if I use mobile network and turn on mobile hotspot, that wifi I can connect without any problem.

Country : india .

Thank you .

1 Like

Same as me,
but i dont have iphone to test it, android didnt work with particular wifi in my country.
Near Bangladesh

I have few android devices and they all work fine the oly time i recived the connection failure msg is when my wifi signal is weak.

What country are you?
So maybe it is because our country wifi suck

If the 25.7 KB/s is your connection speed, that’s pretty slow internet :see_no_evil: . Still, I get this on both Android and iOS on a strong/consistent connection. For people with slower internet, you could try disabling apps that you don’t care about from running in the background, so that more is available to the app in focus.

That speed indicates current speed , not the max speed , technically it’s not accessing data from wifi , if I use the same wifi for iOS , it’s works fine ,
I tested this with upto 200Mbps connections too .

Like I said before , I am experiencing this for 2 years , and tested in different wifi , different android device , different internet speeds.

It’s not about the speed , if I connect 200Mbps connections , still same results, I tested that with my office wifi too …

Same wifi in iphones and ipad it’s fine .

Country : india , mentioned in post too .

Check to see if you have any network protection app. I had and issue around the time I upgraded to 2.19.

I am able to connect fine when I suspend the network protection.

Nope , other games, YouTube , line , chrome browser everything working fine with that wifi . Only this game says like this .

How do you disable internet protection? Using vpn? Thats work but take a lot of energy source

Dont contact pg, they will tell you its your country internet provider

LOL, this is a weird problem i am facing for last 2 years, everything working fine with wifi except this game in android lol , and i contacted PG , they said the normal troubleshooting which doesnt help.
i hope one day pg will find the reason for this issue and rectify it.

I have the same problem for a month, it started around April 10-12. I usually use Wi-Fi (from my router). Suddenly Connection Failures. Mobile network from different mobile operators also does not help, same error. Only VPN help. So I am playing this game only with VPN now.
Country: Russia.
Some players from Russia also started experiencing this problem from April 10-12, and they are now use VPN, so it is not about my internet connection.

I suspect that this is some kind of certificate issue on the game’s server (that is needed to establish a secure connection to the server), I think that the server probably does not want to accept the client’s certificate for some reason - because I can freely ping this server, it is not blocked. Also I can open event page that is located on the same server without any VPN. Maybe the certificate is getting substituted on the way to the server, who knows…
Currently this server is:
519-dot-pgdragonsong.appspot.com = 173.194.73.153 = lq-in-f153.1e100.net (google server)
It changes from time to time.

1 Like

Yes. The app also has a VPN client. Since a couple of weeks now, I have to disable the Network protection to play. Annoying for sure. I have no idea what would be changed. At least I can play now.

I got this information too from my internet provider, something about secure connection and certificate. But i dont know such thing, and here i am going to stop playing after my elite account expired

Isp name ?

Update. Whatever changed with 2.19 was corrected in 2.20. I can now play as I normally did. No need to disable anything when playing.

Since yesterday, the game finally began to load normally without any VPN. :slight_smile:
And the server has changed, it’s domain name is 520-dot-pgdragonsong.appspot.com now. So I think that it was a server problem.

Did it fixed on you? Sometime mine work, sometimes it doesnt

I should say that after some time the problem appeared again, so I use VPN again. :slightly_frowning_face: The game server is still the same. I wish to know why exactly the server refuses to accept the connection…

1 Like