Atlas API Discussion Thread

:thinking:I would like to add autopilot to the list of possible culprits lol

I started noticing all the issues the same day they clos3d the apis, lots of ppl didnt notice cause it was during a pvp.

I know whats causing at least part of the lag but you tell pg to go right and they go left so dont matter if i say something or not.

This lag was bad even before they tried closing the apis on Jul 29th. Unless you mean before that when things started not getting updated as of Jun 6th which would be about right. The lag has been going on and only getting worse since that date.

1 Like

The issues with not being able to see troop counts and in large having the attack button (this may have been slightly earlier) started almost exactly when (if not exactly when) they applied rate limits. And poor google cloud got the blame for it.

1 Like

primarch buffs are always 0

@PGEggToken if Land Shuffle/New Map has been pushed back a few more weeks, will we have to wait even longer to have the incomplete API fixed / updated?

4 Likes

That’s most likely the case right now. We may work on a few small fixes/changes here and there, but any resource-heavy tasks will need to be afterwards.

@PGEggToken

Here are the two things I need:

  1. player.public.read restored as a default scope
  2. 25 castle search expanded back to >100

I can’t have players register until 1. is corrected

I know your servers would appreciate less spamming of that endpoint if 2. was restored as well.

I’m sure other developers have different requests they need before we can move on with the API (since the old endpoints were prematurely shutdown with an inadequate public API). These are the 2 holding me up.

1 Like

back to 200*

2 Likes

Both these are noted and ticketed to be worked on.

1 Like

how about castle elements? that seems to be something i’ve not found yet.

Is there an ETA on this?

I’m assuming it’s just an int variable that needs changing for the castles to go from 25 to 200 and boolean variable to turn player scope ON.

@PGEggToken fetching troop counts for some teams (/api/v1/atlas/team/troop_count) gets an http 500 response.

I suspect this happens if a player on the team has never entered atlas (on both the teams I’ve seen this happen to, they had a very low level alt account in the team).

Intrestingly enough the API says the limit per request is 30.
{"error":"parameter 'cont_ids' is malformed: too many items in list, max number is 30. requesting 26"}
Not that this helps anyone but I think its kinda funny. (Except its quite a bit frustrating getting such an error message as above one trying to find what you’ve done wrong when you didnt but whatever)
Maybe someone should @ them so they actually look at it :woman_shrugging:

2 Likes

We have complained about worst errors than this and they have yet to be solved. Don’t get your hopes up on these api’s getting any sort of review any time soon.

2 Likes

Im happy if they start to look at all of this after land shuffle like they kinda said they would but Im not yet sure if they are actually going to do it.

“Hope dies last. But it dies”

1 Like

We’re wrapping up most of our work on land shuffle this week, so once we have that complete, we’ll be able to work on the other outstanding issues such as API and lag issues.

3 Likes

The new teams are not currently being returned in the teams metadata, any idea when this endpoint will be updated with them?

(there are also 4 disbanded teams still being returned in metadata/macro)

I was literally logging on to write the same thing … @PGEggToken we’d like to track our new pirate teams :rofl: :rofl:

The way this currently functions is that the team has to have an Influence rating change to be refreshed, i.e. they need to conquer a castle. It’s going to take quite a bit of work to change this, so it’s not likely to happen very soon.

Also, I wanted to mention that work was done on player.public.read last night, so please see if this is functioning as intended for you now.

1 Like