Atlas gone after update

just got home, updated the game now atlas is gone, on andriod. cleared cache uninstalled and reinstalled still nothing. you think you could actually fix this game instead of recoloring old dragons,

2 Likes

It was announced a couple of days ago that they would do a maintenance on Thursday. I am tired to link it, please use the search function

** EDIT: ** We got a NEWS message in game about this on 19th June, 21:24 GMT.

Atlas has been down for several hours. Still no iOS update available.

im not talking about being down, the button is gone to access atlas

When they have scheduled downtime for atlas that’s what happens

Yes, don’t panic. This is part of regularly scheduled maintenance. Atlas will be back after the update is released to everyone and they’re sure that the Jenga tower won’t come crashing down if they reactivate it :slight_smile:

2 Likes

That indicates IT’S DOWN. :smiley:

Update out but still no atlas? Hope everything’s alright :laughing:

2 Likes

Lol :joy:

@PGJared

They have not turned it back on because the update has not gone out to everyone.

Updates go out staggered so PG, probably knowing this, is delaying Atlas start to ensure everyone has a chance to get the update.

Granted, this should have been completed yesterday.

Then stop. There’s more friendly ways to help others. If you don’t know how then refrain from replying.

1 Like

Atlas should be up and running. PvP will be remain disabled until around 11:30 am PST.

2 Likes

I was promoting READING the in-game messages and some functions of the Forum :slight_smile: And those cannot be linked anyway. Sorry if this offended you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.