Atlas unplayable

anyone else having problems with atlas since it became atlas from beta ive had nothing but crashs slow movement making it almost impossible to play and since its not going away ive given in not playing it and will start playing it as intended thats if i can stop the freezing slow gameplay non responciv scrolling and clicking i am on a samsung s8+ all i get from pg is uninstall and reinstall which i have done countless times anyone have any other ideas … also tryed on wifi and 4g no differance at all … cache cleared phone reset all the typical easy soloutions done


I have exact same phone. Works fine. Laggy when internet sux otherwise no issues.

Try it somewhere you know has great internet speed. If that doesn’t work, you probably just have too many apps/pics/porn on your phone.


Multiple account on the same device?
How old is your phone?
Battery changed to a new one? (iPhone and Android issue that was revealed last year where the older the battery, the slower the performance)
Updated to the latest iOS or android version?

We’re still investigating known performance issues with Samsung Galaxy devices, in particular some of the newer devices like the S8 and Note. It’s a rather strange issue because it’s not all Android devices, and seems to be highly common with Samsung deices in particular. I’ve gone ahead an added your device information to our issue ticket @GhostlyKratos. (61720)

1 Like

thank you egg tokan … internet speeds always high have very high wifi plan plus 4g all the time no problem with anything else thanks for the replies think eggtoken has answerd my question i hope for a fix soon

on another note im due to get the s9+ on release day do you think this will be the same issue lol

I’d love to be able to answer that question @GhostlyKratos, but until we get an S9+ in-house to test on, we won’t know either.

Let the store know that if it is possible to test it by downloading a game on it and check if it can run it.

This saves you money, time and frustration.

thanks i will try this when i can get my hands on one in store

Well, there is another ONGOING issue you can address as well (using iPad Air 2, latest iOS 11). Saw a non-allied taunter at one of our garrisons. Parked my Rusher there, followed by my Sieger. Tried to attack the taunter and it kept giving me that "Need to move there first"I was already there! So quickly moved off, then back, same darn thing only “Details” was active, “Attack” was dimmed.

This is the same crap I wrote a ticket for weeks ago after a coordinated attack and got the “we’re sorry” reply. Well I’m sorry too. All this talk about adding features to Atlas, why don’t you fix the existing problems? A teammate suggested after I go to garrison to do a list of primarchs and attack that way as he has experienced the same problems. What in the world, he doesn’t work for PG and can provide info for a work around when PG techs do not?

I’m putting in a ticket along with pics, not that it will do any good.

I would try to play around with the Atlas settings that have been added semi-recently, especially the ‘Level of detail’ toggle which can be set to Poor, Low, Medium, or High. I would imagine that just like the main game setting it lower would improve any of the issues you’re having. Among the others in the section.

This is STILL not fixed

@PGEggToken Can we also investigate why it takes forever for a Samsung to load a defense? Whether it Wi-Fi or 4G, when I load a defense on my S7 for the past week by the time I load it, the attacker has already cleared 30% of the base and every supershot I try says network delay. If I try to use a hammer or boost, I lose it but the towers are killed before it is activated. It always took a bit to sync that I lived with, but the past few weeks makes it worthless for me to actually defend.

I sit beside my phone with my alt on an iPad mini2 using the same internet connection and there are no issues. I can supershot with the very first tower.

We’re working on some changes that should hopefully help with the lag on Samsung devices in our next update (not v4.10, but the one after).

The issues on the S7 are likely related to the ones on the S8 as well. Upcoming fixes will hopefully address both.

hope so im struggling to help my team in atlas at all because i simply cant do anything because of lag and crashing

This is still alive and well. You literally can’t do anything at times. Its so much fun…

1 Like

Hey bud not sure if you are still having this issues, I myself have an s8+ and for the first 2 months of playing I was crashing a lot, after trying almost everything I could think of I lowered the phone graphics to 1080p. Granted I do experience some crashes still, but defiantly a lot less common (maybe once a day) and I never really have lag issues. Hope this helps a bit.

I have same phone… works fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.