Axi special packs not found

So when I first started the game today there was this screen which greeted me and I checked the buy now button. It led me to the store with 3 special sigils packs (500, 2500 and 5000 respectively, purchasable once per 24h). Against my better judgement I considered buying one of them, but I give myself a little time to think it through and see where it gets me in season. However when I tried to go back to the store, the packs are all gone! I tried triggering the screen again by restarting the app and clearing the cache to no avail.

How am I supposed to purchase the special offers when I only see Atlas-related packs? Was the offer so limited in time it didn’t even last 24h? @Arelyna

Sorry, it was a TL;DR moment for me. :man_shrugging:

I used to, but not anymore. All I see is this crap. No way to change it to special offers…

Well first of all, it’s not a good deal so I’d wait for the sigil packs anyway. But if you still want them, after trying all the usual suspects (rebooting, reinstalling), I suppose you could submit a ticket and go from there? That might not be a good idea either since who knows how long the backlog is. Tag Arelnya?

I just received a notification that WD was updated, now I see the packs again. I’ll wait a little before asking for this thread to be closed in case the issue come back though…

@ModMat @TheRedDelilah

Please close this thread, the issue is solved. Thank you!