Breeding Castle Access when Upgrading

please allow access to Breeding Castle when Upgrading. It’s hard to remember all the details.

You can access the breeding castle through the hall of research by clicking on an egg you don’t have enough of. It will prompt you to breed more.

13 Likes

If I remember correctly this doesnt work. It just takes you to the breeding castle on your base, not inside the castle. Just like when you select “got to incubator” when obtaining a new dragon egg.

Only way to access the breeding castle while upgrading should be during a breeding event through the event menu

Test it out. It takes you right to the breeding tab. :upside_down_face:

1 Like

I just did, it doesnt work.
Actually none of them even have that option while the castle is upgrading


For super low tiers you can directly buy the eggs for a crapton of rubies but that’s it

You don’t tap on “research”, but the actual image of the egg.

Nothing happens when I tap the egg image

It can be a little finicky in terms of where you tap, but it works for me, exactly as Daedulus shows.

Unless … it is another iOS/Android difference. I am iOS.

1 Like

Im Android. I’ve tried tapping all over, the only reaction I get is when I tap the research button

1 Like

That’s interesting. I’m on iOS, I tap on the area I circled above in the first screenshot and it brings up that message that takes me to the breeding castle.

1 Like

#DamnIOSFavorites
#NerfIOSUsers
#DebuffTheApple

:robot::hocho: :apple:

6 Likes

Just tried on my android phone, works just fine there too.

4 Likes

Another option is going into inventory and clicking on an egg in there. It will pop up and have a button that says “go to breeding”

4 Likes

Now that one does actually work, thanks for that, I never tried it since they added the inventory

Im on android. I click on my inventory and scroll down to the eggs. Click on any egg and it allows me to see all the dragon tiers and bbegin breeding

Can confirm that this works on my Android phone too. (Never knew this was a option before)

Mine required an extra step. I needed to first hit the egg and then tap the “Research” button.


(Tap Egg first then click Research)


(Clicking on Research by itself)

2 Likes

You hit the research button. That requires eggs to research. What you want is to hit the egg (for an egg you don’t have enough off to do research with), then hit breed like what Dae showed you. It’s not that hard. Been this way since 2015.

2 Likes

interesting! very useful tips. Thank you very much.

ya, this also works. thank you.

So after all that… is the verdict that we should just be able to access it when it’s upgrading ?:rofl:

3 Likes