Can’t train troops/ships

I’m unable to train troops/ships (still don’t understand if there’s a difference). Apparently I don’t have enough resources, but I have more fortune cookies and gold than I need for the troops I’m trying to train.

Try going back to the core game from Atlas and retrying; if that still doesn’t work, restart the game.

Edit: And troops and ships are the same, just that ships is outdated terminology from the beta.

I’d rather PG just fix this useless mess they’re forcing on us despite no demand for it

Edit: thanks for the info science

I haven’t run into this personally, so I’ll ask what is probably a silly question. Why does restarting seem to fix it? Is the game showing a different amount of gold/peasants[hats]/etc. after the restart? I assume that the server is probably correct, and that the game client is somehow out of sync (until the reboot) but if that is the case I’m trying to understand in what way it is out of sync for you all. I’ll always check out our internal logs and see if that sheds any light on the situation.

Yes, it frequently gets out of sync, whether after hitting a poacher/mine or after hiring troops. After restarting it’ll usually be missing some amount of gold vs what was displayed on the UI.

I also frequently crash on poachers, so I don’t know if that’s tied to it, though the desync happens regardless.

Whenever I’ve ran into this issue it’s always been the gold that doesn’t display the correct amount.

I think I made a post about it previously. From I can tell the following happens:
Player hits a poacher or mine and is supposed to receive 100k gold minus 20% tax. Visually the full amount of 100k is displayed while actually only 80k went to player and 20k to their bank. After reset the correct amount shows up.

Thanks for the details. I’m sure this will require an app update to fix, though I don’t understand the fine details of the cause yet. I’ve optimistically added it to our January update bug backlog.

Sorry, been out of game for a while.

To confirm when I reset the game I was able to build troops. My resources to build were unchanged (apart from a few more fortune cookies as they’re always generating)

@PGDave Just adding a little more detail for when this happened today:

  1. Hit 3 poachers
  2. Trained the max amount of troops
  3. Hit mine once
  4. Tried to transfer what looked like 380k to a bank but got the “lack of resources” message
  5. Restarted
  6. Logged in to 231k gold, which successfully transferred
  7. Hit a mine 2x, which resulted in 426k gold but got the “lack of resources” message
  8. Log back in to 281k

added 7 & 8

Edit for today (a day after the original post): I pretty much have a ghost 10% tax… and then a random drop in gold.

  1. Mine displays 165k, receive 151k
  2. Mine displays 160k, receive 146k
  3. Mine displays 155k, receive 141k
  4. Tax showed as 0 for all cases above.
  5. After spending 399k on training troops, I’m left with 182k.
  6. I try to deposit that into the bank, and I get the “trying to spend 126k but insufficient funds” type message.
  7. I restart and end up with 41k, which deposits…

Gold laundering :woman_shrugging:
Edit 3: None of the above adds up, but those are as displayed on screen.

@PGDave – the problem is the interaction with tax.

Basically the UI displays your “gold” as the untaxxed amount, yet the tax actually got directly deducted. Restarting resyncs it, so the UI shows the taxxed amount

If you set tax to 0%, the error never occurs

Hope that helps

For my case, it’s with no tax, whether it’s no tax from an owned continent set as home or with a safe zone continent set as home.

Thanks Gox; will investigate. @forScience It’s wild that you’re seeing this even though you’re living at a neutral continent. We’ll check that out too … but hopefully you’ll find a new place to live soon!

@PGDave The “ghost” tax issue seems to have been resolved now, but there’s a new bug where it’ll display as if a mine/poacher run was rewarded twice on the UI but wasn’t in actuality.

e.g.

  1. Do one hit for 169k & UI shows 169k
  2. Do a second hit for 151k & UI shows 471k (or higher), when it’s actually 320k
  3. A full game restart is needed to update the UI

Thanks, sounds like we have some more work to do. I haven’t noticed that yet, but I’ll watch closely for it on my next set of farmings runs and also ask our internal team to help reproduce the issue so we can solve it.

This topic was automatically closed after 30 days. New replies are no longer allowed.