Can't load Atlas after the last client update

Mostly on Android. Crash every time. Thank

1 Like

Our support team received reports about this early this morning, and they’ve escalated it to our team (who’s been looking into it). Once we have an update, we’ll let you know.

1 Like

Hope will be soon. I desperately need 42k sigils to finish my Elite Branch. Thank

me too… I tried everything but still won’t work. i’m worried about my pending timers and eggs. huhu I wish I could collect them for next building event.

Its not just Atlas this afternoon. Chat is not showing Team Names, transferring RSS to a team mate for missions takes 2 - 4 mins to complete, etc.

Push notifications for chat are failing too. Someone needs to feed the hamsters at Google!


I have been having this problem myself since January 13. Are the devs going to refund people their Tribute Egg Tokens etc? In game growth is hurting bad from lack of timers and egg tokens for those effected to the point I’ve personally watched several people quit the game entirely. That’s not even touching the fact that we cannot spend/gain Glory with the Atlas season coming to an end fairly soon…

1 Like

We have few teammates who cant even load the game

I go collect prizes black screen i g deposit black screen. I o to hit someone stays on base screen needs reboot getting on my nerves getting cant attack invaders have to constantly reboot

Still broke. Atlas crashes or hangs the client. Cant claim prizes.
Troops dont train. I’m bored.

I’m going either storm or virus hunting while we wait.
Just yank it down, run maintenance and restart. Something is borked.


1 Like

Ugh! It worked for a couple of hours and now crashes every time… Again :frowning:

Yes, me too

@DragonPunch Any update on this? People would probably appreciate hearing before the weekend. Atlas downtime is always a big deal due to pvp and timers, but especially at the end of a season.

1 Like

The game is plain broken.

Time outs, roll backs, can’t claim prizes, prims won’t move, troops won’t train, and its Friday afternoon.

PG is no where to be seen. End of the season is rolling around and there might be some pathetic apology gift of 20 chests on Monday.

Just another week of Woe Dragons, and nobody can figure out why participating player counts keeps getting smaller and smaller.


Then the all time favorite, stuck at 99 percent

1 Like

So the plan is to leave atlas broken all weekend? I guess it just isn’t broken enough to matter.

Trying to attack an invader in Atlas.

Good luck trying to craft.

1 Like

Sorry I don’t have much of an update folks. The team is still looking into this issue. They’ll resume on Monday as we’re at the EOD.

What we’ve seen so far from our end is that it’s mostly Android players that experience this issue on usually on either older devices or on an older OS version (we’re seeing a lot of players on pre-Android 10 sending tickets to Support). I recommend updating your OS since our game is optimized for the most up-to-date OS versions (which is usually required by both the Play and App stores). If anyone is experiencing this on Android 10 (API Level 29) or on iOS 13.3.1, please let me know.

Sorry again we couldn’t get this sorted out before the weekend. We’ll be assessing the impact of this issue on Monday and after we’ve concluded our investigation.


I’m not buying a new tablet just for this game when I just renewed my WoW subscription after 2 years. My PC runs that game just fine.

Clash of Clans runs just fine too. Maybe it really is time to move on.
Y’all have a good weekend. I can’t even do my “job” as an officer.

@DragonPunch Uhm… Android 29 doesn’t exist, most recent version is Android 10 which was recently made available for the majority of but not all devices yet last month, android 9 is like a year old… maybe 1.5 years old, did anyone bother to fact check issues? Or is someone assuming 9 is an old OS?

FYI I am a SDET that runs a QA/QC department and deals with hundreds of mobile devices for our testing on a regular basis.


Just corrected my post. I meant Android 10. Sorry about that…


I am having this on my ipad. Its a 13.3
I crash and spin cant swap stuck in offline struggling to defend teammates in war.