Egg missions not showing up

When i try to access the egg missions blimp, my screen is blank and then crashes. Does anyone else have or had this issue and/or know how i can fix it? Ive contacted support and ive tried everything they listed and nothing has worked. It has been like this since i started my acct. i use iOS.

I don’t remember seeing this on the forums, other than someone who was too low level to get missions, but some iOS players with issues have reported that the game is more stable after updating to the latest iOS (Settings > General > Software Update). Is yours on an older version?

Yea i have latest ios update and war dragon update…its frustrating because idk what my missions are :confused:

My suggestion in the interim would be to start an attack and when you go to select your dragon there should be a tab on the left of the screen (android) that will show current missions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.