Egg Token Glitch, Get a Dragon Egg quest?

Hey, I just started this game very recently and am still going through the motions of learning the ropes and such, but I fear I’ve come across a game breaking glitch of sorts? I had Orin tell me that I’ve gotten new Egg Tokens and should make a new dragon out of them, but when I try to, I can’t seem to scroll through the menu to access what the game wants me to access. I’ve tried breeding a dragon, but now I’m even more stuck since I can’t end the quest for whatever reason (I’ve restarted the app and un/reinstall the app) so I can’t upgrade my incubator. If I did something wrong, please let me know, but I can’t progress through the game. I have no idea how to send out a ticket or anything.

I’m not sure exactly what you’re referring to (someone here who makes alts probably has a better idea) but I’m sure any and all screen shots you can provide will be of help.

To make a ticket…



1 Like

So I got through the motions of starting up the app, get greeting by Ash to ‘Breed a Purple tier dragon for the Andriod dragon’, and then Orin pops up with ‘Mission accomplished, Commander. Use these egg tokens to breed dragons’. It has me select the Breeding mountain to breed another dragon, but I can’t scroll through the menu to the side it wants me to go to.




It won’t allow me to select any other part of the menu except the Purple tier dragon on the top and I tried breeding for it. It’s too high of a level for my incubator and I can’t upgrade it since I can’t select anything.

What about Kinnara?

I can’t select it. I could select Trollis (which I rolled the egg for and can’t upgrade my incubator for) and I can select Merk.

What does it say when you click on Kinnara?

Those are red dragons. You need to breed a purple dragon. You need to level up your red dragons to be able to breed the purple ones…

EDIT and that means leveling up your incubator and whatever else you need to do

I can’t select it, it’s like I’m not tapping on it. Trollis and Merk are the only dragons I can select to breed for the on the screen

There we go, sorry I can’t read so good lol. Level up dragons to breedable, upgrade incubator or whatever.

Edit: Lol did you copy my post with you edit

2 Likes
  • Each dragon is a number of parent sets (i.e. two separate dragons that can breed it).
  • Those parent sets are typically from the tier before (so to breed Purple you use Red dragons etc)
  • If you don’t yet have the parents for a particular dragon, you will not be able to select it in the breeding castle - therefore, as you can only select Trollis and Merk, it means you only have the parents for Trollis and Merk.
  • “So how do I know what parents I need?” I hear you ask? Well, go visit:
    https://forums.wardragons.com/t/reds-master-breeding-paths/
    Read the entire thread (if you can) and then open Red’s file. If any questions, ask in that thread.
  • Follow one of her paths! You won’t regret it. Don’t ever ever just breed whatever is available. You will benefit from following a path when the time comes.

All of my red dragons are level 6 or higher except for Ember (whom I’m leveling as I type), but I can’t select my incubator to upgrade it, the quest is making me select the breeding mountain.

Can you upgrade the breeding mountain? @Jonesy help lol

I can’t until my player character reaches level 7, I’m halfway through level 6. I have to upgrade my storage in order to have enough resources to upgrade anything else

Can you post screengrabs of exactly what happens?

God you’re lucky they changed ember recently… :rofl:

4 Likes

So upgrade your storage, then upgrade another tower, then upgrade your breeding castle, then upgrade your incubator.

This game has a number of gates to stop you doing things too quickly in one dimension and neglect others. Just follow the gates and you’ll find your way out.

The game isn’t allowing me to select anything on my map. I can go into battle upon other islands, go into system settings, to into the store, etc. When I try to follow the quest markers on my screen, it won’t scroll to the left.


So I’ve tried to select things on my map and I can’t do any progress. It’s like the game isn’t registering my selections, but it does allow me to select the mountain, to breed dragons, and to breed Merk and Trollis. I can’t select my incubator, my storage, my den; anything on my map

I did a mini yell of “NOOOOOO!” in my head before I remembered they did that :rofl: :t_rex:

5 Likes

No idea then, sorry. There’s gotta be something you can do to move it along. Sorry.