Glitch/Bug: Cannot Achieve 100%

The base at the end is bugged so you can only get 99%

Something like this?

1 Like

Pretty much lol

Does this count against your troop win/loss ratio at all since technically you can still 5 flame the base with 1 dragon if you “quit” after the first dragon gets to 99%?

1 Like

I’m seeing it too

Could you please file tickets? It makes it easier for us to send to the engineers.

We had this earlier with not beta base
There was a perch which couldn’t be killed
It looks like you liked it,but it keep shooting with alive dragon and you’ll get only 99%

I had this problem yesterday. I still got a decent kill ratio and decent glory. I don’t think not killing the home base makes that difference. I killed 7k troops and lost 2.5k and got 1900 glory. It’s better then it had been in my opinion.

If you don’t 5 flame, you lose half your kill ratio.

It is possible to 5 flame without killing the castle, but you have to quit and not use a third dragon


We are urgently investigating this. In the mean-time, you can still get 5-flames by quitting the battle after getting 99% (all but the missing castle) after you beat it with your first dragon (or first allied dragon).


I think it still messes with the ratio :cry:

@PGDave can you please summarize the system penalties when you do not five flame (like using 2 own dragons or when you swap for the team mates to give everyone glory and would use 5 dragons)?

Apologies if that’s already discussed and I didn’t find it

1 Like

All else being equal (which it rarely is), 5-flames will kill 2 troops for every 1 you lose. 4-flames drops that to 1.5:1, and on down from there. Primarchs, etc. can all affect the troops lost by each side too.


Bumping this.

Are there any people here who still experience this missing castle at the end of the Atlas battle map? I would love to chat with you.


since the update i havent noticed the missing castle anymore.

Yes,had it today in battle.Can give player name,if needed

Can you give the player name, as well as see if it happens everytime you attack that player?

It doesn’t happen for you attacking that player in the regular game?

Also you have tried re-installing?

Had it twice today with two different players, from the same team. Both had destroyer prims as well, not sure if that has any correlation.

1 Like

Player XxDanMc1Xx

Looks like there is huge problem with server today
We noticed few issues in Atlas:
1)Taunter with 1 troop been able to Taunt another primarches against primarch with 1k + troops (which is not supposed to be,according to Dave)
2)Second attacker been kicked from the battle multiple times in different battles with different A and B
All players had perfect connection
3)I reported in ticket (number 974748 )
Someone killed me at NML
After this I resummoned my Sieger at my home island and put 1,5k troops there
Did xp run ,opened Atlas and saw that same person killed me second time while I was at my home island (which have blocker,so it’s technically impossible to sail there)
Report shows that battle was at poacher,but it’s absolutely wrong
You can see it if you’ll check my account
Please,fix it,because it’s insane,that you can loose troops via server error

Could you send me the player names?