Grumuk Cloak Spell Greyed out?

His cloak spell is greyed out from the start of a flight despite being fine a few days ago. Tried restarting the game but still the same problem.


1 Like

My guess is the update did this. I don’t have him but these updates cause more bugs to show up than they claim to solve.

Can you file a ticket for this and DM me the number? I will forward it to the right person.

7 Likes

Sure, thanks.

This is happening to me too

1 Like

Support is already aware. But make sure to file a ticket🙂.

2 Likes

Yes. I parked that worthless festive. Gramuk is a waste and bummer for sure.

On the bright side you get Draconic chests for completing his branch. It’s not a complete waste only a waste of a dragon.

3 Likes

Only using him for the caves 10x bonus lol

1 Like

I regret getting Grumuk so much right now… spell still not working

But is still not fixed yet. I submitted the ticket as well. No follow up respond from support .

Getting fixed in next DCON release on Tuesday

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.