IF - Instant heal no longer working?

It used to be if you used an Inner Fire and your dragon didn’t take any damage there was no heal time. It I have noticed this weekend that’s no longer always the case. Sometimes I swap out right as the attack starts, and sometimes I am swapping at the end to stack IF’s. But the majority of the time the dragons used still need to heal even though they took zero damage.


I’ve noticed that too. It didn’t seem to happen all the time, and I didn’t have many IFs to begin with, though, so my observations may not hold much merit lol.

1 Like

I’ve noticed that it glitches out sometimes depending on what dragon it was stacked on. It didn’t give me any issues when I had it on Avyx (he was 3rd IF dragon). I had absolutely NO idea if it wasn’t working correctly with my lvl 1 Ember (2nd IF dragon), since Ember heals so quickly anyway lol. It also wasn’t affecting my alt account with Leo, Danzing, and Mune (who were swapped right away so this account could finish the run) and they were ready to go for the next attack without the need for a heal potion.

1 Like

I’ve had that happen too I even submitted a ticket once but as usual they were clueless tried to tell me it wasn’t relevant for that event … but some it worked for some it didn’t they were just ignorant… try unequipping then re equip no guarantees but it’s worked for me

Same here.
Spend more then 100 IF, been healing all dragons

If your dragon takes ANY damage, the inner fire instant heal won’t go into effect. And I mean, any damage…1HP/500M still counts. Hope this helps. Personally I’ve had no problem with this.

I too had issues with this at the end of battle I would swap out so no defense towers around and I still had to heal my drags. Avyx was the only one without an issue.

1 Like

For me it seems to be dragon-specific. Certain dragons will heal and others will not. Very annoying.


Sent a ticket for this last pvp, and got PG super vanilla response with a link to known issues in game. No compensation and a lot of heals wasted. I dont think i had this happen this event but not certain.

if you are going to use a second dragon and a third dragon only for the inner fire (meaning, you are owning the base by a lot) then use red tier dragons so that it takes minute to heal in case it doesn’t work on you.

im using Nec Noc and Avyx - no heal time.

but figured out if i do that with Ferga or Hau i always had to heal them

Doesn’t work on sekhem

It seems to be affecting only some dragons, based on my experience.

Annoying, but not enough for me to complain. I suppose if I did not have thousands of heal potions, it would be a bigger deal to me.

But yeah, it’s an “inconsistent” problem.

Yeah, as has pretty much been said already it just depends on the dragon. Can safely say it works fine on Avyx and Ember (if you’re one of the unlucky ones not to have a lvl 1, mine is lvl 6 and would suck to burn a potion on a 3-4 min heal time)

Yea, it seems to be affecting only some dragons

Same. I think this should be reported as a bug, imo.

1 Like

Well since I’ve been playing long enough to buy my elite with rubies I think I have a pretty decent idea how it’s supposed to work. LOL

When I say I swap right away I mean right away, as soon as the screen loads. It has also happened when there is nothing left to do but blow up the den so there’s nothing left to cause damage.

Ok makes sense. Idk then

Haun glitched everytime and needed to heal

hauheset definitely doesn’t