Lag in Atlas makes the game unplayable

@PGDave

The title says it all. I am aware this could be a server issue, it could be a programming issue, it could be a combination.

Any time we have had a larger coordinated event, Atlas has ground to a virtual stand still for all involved.

I have videos and screen shots from the engagement today to help illustrate the severity of the problem.

Battles were not registering, primarchs couldn’t be moved, for some atlas wouldn’t even load.

I have submitted tickets before, but nothing has been done.

We had multiple players that simply couldn’t die. Even after growing tired of having to “move” 40 times before actually moving, and deliberately attacking much higher primarchs and losing, they still had the exact number of troops as before and the battle didn’t register.

Let me know what information I can give to help you look into this. It really makes this part of WD not fun at all.

Thank you.

2 Likes

Yes @PGDave :
Tonight a large assault was launched - we got “Failed at waypoint” with every move. Hits not registering, glory points not counting, troops not being deducted … and so forth and so forth.
It’s ridiculous.

1 Like

I just lost 10k troops because of your glitch!
It’s absolutely ridiculous!
I did 5 attacks and non of them haven’t been registered as beta attack!
My backup saw my invitations with troops count,so it was obviously atlas attacks
I’ve been hitting garrison and players,even tried using primarch menu!
Any single attack haven’t been counted!
Then I made a call with my backup
I started attack and it shows as non beta (only with rss) again
I gave up,left and lost 10k troops!
It’s ridiculous!
I hope you can compensate it and will fix it
@PGDave

3 Likes

Atlas servers for group attacks are starting to remind me of Game of War weekend event lag, unplayable…

Dave,

I won’t keeping tagging you. Everyone needs days off, right? :slight_smile:
But now that the dust has settled, and my immortal troops and primarch have finally died, I cannot summon my primarch again. I’m sure you are aware that you cannot do much in Atlas without a Prime.

I have fully closed the game and rebooted the device.
I have fully closed the game, cleared the cache (for the game), and rebooted the device.
I have booted into recovery, wiped the device dalvik cache, and restated.

No luck.

So, not blaming you–I’m sure the penny pinchers that don’t want to pay a little more for server memory, CPU time, and bandwidth have a lot more to do with this than you do.

But if this is where the game is headed – money has to be spent somewhere. It is extremely unlikely my team is the only one experiencing this issue.

Lag kills games. Especially when you can spend 4 hours trying to fight, and more than three of those are spent tapping over and over and over to move and being told a “&&%$% waypoint could not be set.”

I don’t anticipate you’ll even see this until Monday. And that is fine. But if you have any pull at all with the keepers of the purse, money needs to flow into the servers man. This isn’t working the way PG or the players want.

2 Likes

There are many ways to address lag. I won’t go into all the details. But plenty of games deal with it in more effective ways than just not working.

Recently encountered a similar problem with my team and some friends. I personally did over 10 attacks and had backers every time, but only 1 got registered!
All my teammates and friends, also the adversaries, couldn’t do much, we could attack, but nothing was registering. So we lost our healing potions/ boosts and a shitload of hours being stuck!
And Pg won’t respond to why this is happening. :exploding_head::rage:

1 Like

Its not just Atlas, the whole game is laggy. Transfers disappearing, incorrect rss amount shown, its just getting worse lol.

3 Likes

I have reported this issue already some time earlier here, think we are referring to the same ally attack:
http://forums.wardragons.com/t/atlas-completely-hanging/28071

It’s not just large attacks… we are seeing prims glitching between mines and castles, same with portals. AND banks not transfering or only transferring after a secondary toggle is made i.e., sending a different transfer triggers the first one to complete :woman_shrugging:t4:
It’s a hot mess out there :stuck_out_tongue_closed_eyes:

Any solution for: “Failed to use Portal: Primarch not at portal”.
Currently my primarches can do nothing but suicide myself!

@PGDave

Pinging you again not to be bothersome, only to ask another specific question.

There have been many rumors of the need to “upgrade” the servers. But I am curious, what is involved in upgrading hosted virtual servers? Many hosted cloud servers even provide for on-the-fly scaling (both AWS and Google provide this functionality). Yes, the bottom line cost goes up a little, but the customer (in this case, PG) ends up paying for “better” servers when demand is high, and the servers automatically drop to a predetermined baseline value when demand drops.

Perhaps I am mistaken. Perhaps WD is NOT hosted by AWS and/or Google. IP addresses rarely lie about who owns them. But the information can be misleading if one doesn’t know what he’s looking at.

Yesterday we had a battle and it was impossible to do beta attack,using island menu-all attacks been counting.as regular!
Then I noticed,that you can do beta attacks only if you’ll press on enemy primarches.
It helped a little,but then I got new issue-i haven’t been able to hit garrison(because attacks threw island menu been counting as regular non beta attacks)
@PGDave
Maybe this info will help a little

Primarchs are currently pingponging between rotating around the target location and the center; it’s like they’re drunk and lost, pretty much. So, to attack anything, you have to catch it at the right moment to initiate. I haven’t tried PvP attacks after other people have had issues.

2 Likes

It’s not just prime movement. Try setting your home. Try attacking. Try defending. Try virtually ANYTHING when a significant number of people are in atlas. Let me know how it works for ya.

We had a pretty big skirmish last night. Probably almost a war. Few attacks registered, even late (some did count later). Riders did gain XP (or appear to have, but little or no glory was awarded, and of my 30+ attacks, I do not think any counted (except for rider experience).

When I grew tired of the situation (after spending about 4 hours of my life trying to move and then making attacks that didn’t count, I finally started attacking a player many levels above me who also had a max level primarch. Naturally, I lost, but even after losing 5 times, I still had all my troops. I rebooted, cleared cache, all the usual stuff. Everything was still there. So, I gave up, and after about 10 minutes, I was able to get the waypoint home to stick. A few hours later, I got hte message my primarch needed to be resummoned, but I could not do so. It was not until this morning (12 hours later) that I could summon my prime and revive my troops.

This morning, my primarch is gone and all my troops need to be revived. This is not a problem, but I do not appear to have received any glory. My attack history shows my last attack happening several days ago.

This is a MAJOR ISSUE. And PG does nothing. I was nice in my note that flagged Dave, both because I remember when he was in charge of the event team, he’s a cool cat, and the problem is likely not one he personally can resolve.

The servers ARE hosted. I do not know of any situations in which AWS or Google allows for customers to provide their own hardware. (and for those of you you will say these are authentication servers only–I assure you, that is not the case. Do a packet capture, if you know how. You will see I am not making this up. Resolving lag would take a few minutes from an admin (probably longer from the business people). I have worked in numerous cloud environments. Scaling up your servers is a few mouse clicks and approving the additional expense. Done. They go live with the new settings almost immediately.

That we as players tolerate this lack of service (oh, yeah, the TOS say PG doesn’t actually have to provide the service they are charging us for–go read it) and that we believe the “servers need to be upgraded” line we have been fed, is unreal.

I won’t post the IPs of the servers, since that could be considered a possible TOS violation (although it is freely available to anyone who had installed the game).

I’m not threatening to leave, and I’m not threatening to stop spending on elite.

I am saying that if this were a PC game, and not a mobile game, PG would already be out of business. PC gamers (console games too, but not quite as much) are far more organized and far more effective at using their voices to hold the companies providing gaming services to an acceptable standard.

If Atlas is the future of the game, which Harbinger implies, intentionally or not, this must be resolved.

I may have lost nothing in all my fake attacks, but the defenders should be angry that I was able to attack over and over with troops that had hours ago been destroyed. They didn’t lose any troops, but they certainly spent a lot of hammers and defense and attack boosts–all for attacks that don’t even appear to have happened.

Like I said, I know this is bigger than Dave, and I don’t blame him for any of it. But If there is one person I think can bring change that helps the players, it’s @PGDave.

Any wagers on if he supported the mega coin or not? :rofl:

Obviously, I cannot and do not know if he did or not, but it is so inconsistent with the events he made for us for two years (or more, maybe), it seems unlikely.

Plan of action:

  1. Clone Dave.
  2. Give Dave(s) control of all aspects of the game.
  3. Make WD Great Again! (allusion intentional, but does in no way reflect my political position).

Real plan–pay a little more and get servers that scale to meet demands on-the-fly. PG can afford the expense.

3 Likes

Dave was tagged,because he is the person who collects info about Atlas and obviously,it’s his specification)
I hope that info will help to find solutions little more easier. And,of course,I’m mad-now I need to build 25k troops this week to catch up my team troops building requests😹
And all this was pointless for me,because my primarch ang Rider already maxed and I can’t transfer GP to another primarch/Rider.
And since it gave me awful amount of GP,I get only 2 first event prizes,which obviously doesn’t worth tropps,which I lost )
BTW,it will be nice,if we will be available to transfer GP from one rider to another ,using rubies (like in feeding event).

Could be because of fhe meltdown and/or spectre patches. AWS was having performance degradation as early as mid Dec.

Could be. I certainly will not minimized Spectre/Meltdown. My work requires I stay abreast these sort of things. Few people realize the significance of the flaws and the exploits allowed by them.

BUT… that I know of, the patches were not available mid-December. So, I doubt this is the cause, although it likely is not helping.

For those who don’t know what Mr. The Plague (love the allusion) is referring to or why it matters:

That’s the plain English version. There are some very good technical papers available, if that’s your thing.

I’m not trying to beat up on PG. Lag has been a problem for a LONG time in this game. I do not think it’s accurate to blame a long-time problem on a recently identified, and even more recently patched, problem.

This is the first bloodlust event where I will finish with 0 points. If prizes still gave out a lot of expedites, I’d probably put up with the incredible hassle and aggravation. The large battle experience is a complete cluster: lag, attacks seem not to count repeatedly, unresponsive commands, unusable UI, etc. But when you combine mediocre prizing with an abysmal experience, it’s simply not worth my time to participate. Please look into server capacity upgrades, a UI pass focusing on large scale battles, and anything else that can improve the core experience here.

3 Likes

We all want immediate response. The game actually conditions us for this and then takes advantage of our desire. But I understand the nature of IT. Few things are as easy as they seem (or sometimes they are too easy… It’s not plugged in or the hamster wasn’t fed).

Ofc, this lag (and the associated problems, most of which appear to be time sync related) is possibly a rather involved problem.

Even if a solution is not immediately available, I do hope PGDave can give us some information. It’s clearly affecting many people from all different leagues, geographic locations, and areas of atlas (this may not matter… Maybe the whole thing is treated as a single entity… Breaking it apart could possibly help the issue).