New update 3.70 not compatible with Samsung 7 Edge on Android 7.0?



Hello Team! @PGJared @PGDave

Upon seeing the announcement for the update 3.70 for War Dragons I immediately went to the Google Play Store tried to go about updating.

However: Somehow, in the release to the Google Play Store the update states that War Dragons is no longer compatible with my phone.

I have a Samsung Galaxy S7 Edge running on Android 7.0 (Per the attached screenshots of my phone specs). I have attempted to check for any updates released by my wireless carrier and I show that there are no further updates for me to download.

Please advise on what I should do as this happened with the last update (the one that included the UI update) where I was not able to access my War Dragons account for at least 2 days into the event.

My in game name is ZerokiWolf.

Thank you,


EDIT: The remainder of my screenshots are in the replies below. Something about new users only being able to post one image per post.


Update 3.70 Release Notes




Installing of an Update Button? Share your thoughts



@PGDave and for me the Beta crashes all the time when i click a building , goldmine or poacher in Beta

-Galaxy S8 here


Bumping this topic to make sure someone from PG actually looks at this


Simple solution there wolfie. Buy a new device. Why bother the hardworking folks at PG when you could simply drop a few hundred of your chosen currency?



@Sumatan Thanks for the heads up.

@ZerokiWolf I’ve pinged someone to get back you.


@ZerokiWolf One of our engineers got back to me on some troubleshooting steps to try and fix this. Could you try them to see if it fixes your issue?

  1. Go to Settings -> Apps -> All Apps, find Play Store there. Clear its data and cache, do the same with Play Services. There might be old data that’s not being overwritten by the new, so clearing this could help with a fresh state.
  2. Make sure your Play Store and Play Services apps are up-to-date.
  3. Try downloading while on a Wi-Fi network if you aren’t already. Sometimes network configurations could cause issues.


@PGDave @PGEggToken @PGJared

Google Play Services - Cleared data and cache, re-logged into Google Play - App is up to date, version 11.5.18.

Google Play Store - Cleared data and cache, re-logged into Google Play - App is up to date, cannot update further. (See screenshot)

When I go back to Google Play through the War Dragons link update link from your Facebook page, it is still saying that the version is not compatible with my system; therefore so cannot update still. (Please see screenshot taken today).

As you can see, I was attached to my home Wi-Fi at the time of taking said screenshot.

Still seeing “Your device isn’t compatible with this version.”

Next step please.

  • ZerokiWolf





Bumping again.

My last session of clearing caches and data did not change the fact the Play Store literally will not even allow me to download the game. I can’t even search for it. I have to get to the page through your Facebook post with the direct link to the Google Play Store.

It seems like somehow no one knows why Androids can’t update. Peter from your support team had the crackpot idea of uninstalling the game when Google Play Store will not allow me to even search or install for the damn title under normal circumstances and I’m being forced to have to rely on the update announcement link from the War Dragons Facebook page.

C’mon PG! :rage:


I still say you should just buy a new device.

Kidding, we’re on the same team. Hope they get you back online soon, I need backup!


This is high on our priority to fix right now–we haven’t left it by the wayside.


Hey sumatan, messaged you in game earlier and figured out how to log in haha. the way I got my game to run smoother/less laggy is go into your “Developer mode” option. It is located in the “system” tab in your settings. If you do not see developer mode in the systems tab you will need to activate it. To do so goto “about device” and tap on “build number” 5-6 times this will enable developer mode. Ounce your developer mode is enabled go back to your system tab in your settings. From there scroll down near the bottom of the options until you see the “monitoring” section. Then tap on “OpenGL traces” and select “systrace (graphics)”.

Currently running Android 6.1 (Marshmellow) have not figured out Android 7.0 issue.

It is important to note that I am not 100% sure if this is the best settings for optimal performance but it decreased lag for me dramatically.

another important note I am not some tech guru and have little knowledge of what OpenGL even is haha.


My Samsung s7 edge is also having issues updating to the current version of the game which is now 3.71.


I have a new ZTE X2 tablet Android 7 and am having lot’s of glitches. Hopefully this will be fixed in time for the feeding event.


@PGEggToken @PGJared @PGDave

So has the fix for this issue been abandoned? There’s been no update or even acknowledgement on this issue. I’m playing on an HTC One M9, less than 2 years old, up to date on all software and now this game is incompatible with my device. How is this not your #1 priority to fix since its clearly not an isolated case? Downloading this game off apkpure isn’t always reliable since they don’t always come out with updates as quickly. When is this going to get fixed?


I haven’t been able to login today because I can’t update. Apkpure hasn’t updated and it’s a required patch now…


This has not been abandoned, and I believe it’s in the 3.80 update fixes.


We’re sorry for the confusion! Looks like this “Device not compatible” error message is related to an issue with the Google Play Store, since your device should be compatible with our game. Google is currently looking into this, so hopefully they’ll get this sorted out ASAP.

As a temporary workaround, Google suggests clearing Google Play Store’s data from your phone and then trying to install the game again. To do this:

  1. Go to Settings
  2. Go to Application Manager
  3. Go to All
  4. Go to Google Play Store
  5. Tap on Clear data.

Hopefully this’ll be resolved soon. Sorry for the extra steps, gang!