New Version Please upgrade to the newest version 4.21 Issue

I tried to load game and I am getting a message to upgrade, but when I go to Google Playstore to update there is no update. Help can’t get into game.

same here. since when does the game not allow play on an older version? if there even is a newer version, my play store page says I have 4.21.g installed

Yep. I also have the same issue but no problems with the alt on ipad


Same

I have the same issue. When I load the game it ask me to upgrade to 4.21. I have then opened and same message. Uninstalled then installed fresh, same issue. Game will not accept I have now updated.

Yup my iPhone logs into my alt just fine but my android says there is a newer version to update to.

Same here. Tried uninstalling and reinstalling. Still no go…wtf…

@PGCrisis @PGJared

2 Likes

Sorry about this, folks! We’re currently looking into this. We’ll let everyone know what’s going on as soon as the team has an update.

8 Likes

Fantastic job PG :clap::clap::clap:

Same here too

It’s ok, thx for doing a great job

Same here

Same problem, I cant get in the game…
I already submitted a ticket for support

Please try full-closing and restarting the game. It should now be back up.

1 Like

This is now a known issue guys. Just wait for updates further, as posting “Me too” will just further hide the official post saying PG sees it.

1 Like

Same for me. I even uninstalled and reinstalled twice.

same here

Thanks that was a quick fix…

1 Like