Points not registering in fight pits event

Every time it’s something.

That’s how we know we are still playing War Dragons.

3 Likes

Do you mean the team rank points? Will we get those before the first round ends?

Same her Lx no points after 30 minutes

I’m getting points :man_shrugging:t3:

Is anyone on this thread (outside of @Lutrus) still not receiving their points?

Team achievement rewards are what are not currently working. Our team has passed listed requirements for prizes by the prizes are not distributing

2 Likes

:thinking: Lutrus is stealing all the points.

1 Like

Looks like our team achievements aren’t working either.

Not receiving team achievement awards here either. :frowning:

Same happening with my team. And was shorted one attack also

So many bugs Arelyna… Energy packs not being added to my account, then ten mins later I get 56 energy.
Also I’ve lost battle invites to the chat freezing issue (still going after months)
I have already sent a ticket but I doubt I’ll get my energy packs back :expressionless::pensive:

Just talked to the team and the team achievements not recording is being looked into. People should be receiving their individual points.

1 Like

Could you look into my problem? Since we are so good friends? :stuck_out_tongue_winking_eye:
Pretty please

Still no team achievements…

Re-check just popped up for me

Team achievements working for me also.

They should be working for everyone again! If they are not, please let me know via PM.

Yup, just popped up, thanks.

1 Like

Some of my team as well as myself not getting points