Primarchs "delayed" at bases

Hey @PGDave there seems to be an issue with lots of players that when out travelling between bases in territories that are not ours (but we have had passage on for a long time) that our primarch gets “stuck” in some type of loop when trying to leave a certain castle.

What happens:

  • travel through an allies land (passage granted)
  • primarch at some point stops moving and “delayed 17,XXX days” message appears in travel location planner
  • you can click anywhere else and “move now” your primarch and it will attempt to move there, sometimes completing it’s journey sometimes not.
  • sometimes the primarch will all of a sudden get teleported back to said castle and the delay timer will reappear
  • sometimes the primarch will reach the destination, but as soon as you click to move again or do an action the primarch is teleported back to the original delay castle and delayed again
  • sometimes it even tries to redo the path transfer and fails
  • this delayed primarch can’t kill itself by attacking and failing against Garrison’s with enough troops to kill
  • this delayed primarch cannot be killed by enemy troops even if I request it

This seems to be a fairly widespread issue with 4 or 5 of our members stuck today and others now reporting being delayed at bases.

I can get a video of this if you require



I can’t find my ships. I can’t resummon my ships. I can’t move them. I can’t do anything. My prims are literally gone but show they are there but level 0. If I go through my contributions page and click on the prim I get a endless black loading screen :man_shrugging:


Same problem I’m having. Level 0 primarch and can’t resummon. It doesn’t show up in ‘my assets’ list either.
If I restart atlas I can see it briefly (for 1 second) and then disappeared again.

1 Like

Same problem. I keep moving my primarch and when I come back it is back in the same spot as where I started. Frequently the primarchs have also disappeared from the map. I can’t find the icon for them to tap on and when I look for them in the list it says they are both level 0 and I can’t tap on them to move to them/ find them. The only way to find them is to manually move back to the last place I saw them.

1 Like

Same issue here and our neighbors. gave them passage and still showed delayed🤷🤷

1 Like

Same issues as all above but also can not access island for transfers. Black screen pops up with loading message only. There is also a phantom ship parked at the island that I can visually see on some angles only.

1 Like

Same here! We are getting delayed at castles we’ve had passage through

I am having the same problems as well. My primarch is stuck in a loop between two of our bases. It says it is traveling but is at the same base again over and over. Also getting a black loading screen when going to manage.

@PGDave we are also experiencing primarchs stuck in loops, including enemy primarchs stuck at castles that have passage and banks transfers glitchy. :see_no_evil:

There are also times when it says our bases are locked down by an enemy primarch and there isn’t one there. Unless you added a cloaking device to primarchs :thinking:

1 Like

Also getting lots of bug reports about the primarch delays/wonky travel and bank xfers are a nightmare (the UI is basically unusable).

I’m having some of the same issues as the OP. Make a mistake and try to move now back to the island I’m leaving and it won’t let me. Then it stops after it hits the fist island even if you have it set up to travel farther.

There’s a quite a few members on our team having the same issue. When I first logged in today I was able to move around fine within my home territory. I then tried to travel to our sister territory to hit Poachers by passing through an Alliance member’s territory (passage was granted) and then got stuck at their base… Bleh… :crazy_face:

Thinking I could just summon my prime again, I tried to kill prime by attacking and losing on one of their members but he didn’t die (hearty little bugger now)… :rofl:

A positive note for those in a similar situation… You’re still able to hit mines and poachers. Tap Move Now on the mine/poacher you want to hit and you’ll get there via normal travel times. Quickly hit Attack once you’re at your destination and make your run. After your attack you’ll snap back to where you started but at least you go your run in… Silver lining… (yeah, kinda weak, I know)


Same here, it says delayed , and even if i wait it return where it was hanging…

And if i try to open event or free item, it load but not open… Its lagging everywhere and reset somehow to old place :x

For our Bases it seems to have been fixed just 5 minutes ago…?!

It looks like there were some server delays causing this, but resolved sometime around noon today. Is anyone still experiencing issue with level 0 Primarchs?

I am still experiencing the 0 primarch.

I am still have level 0 Prims and still unable to open any screens. I just receive a black loading screen. Also one Prim is lost and bouncing between islands.

Thank you @Bunny and @HaileyBears, we’ll take a look at your games to see what’s causing this still.

1 Like

I’m having the same issues, one of my primarchs is missing. Many on my team are experiencing problems as well.