Primarchs "delayed" at bases


Do peoples’ primarchs with issues show up as delayed (white, glowing border around the primarch) at the base they’re trying to leave?


Mine does at first glance but then goes away when it starts moving. It’s getting tired and wants off the treadmill :stuck_out_tongue_closed_eyes:


Yes, sometimes the glowing shield is on permanently, during other logins it flashes, as if the prim is trying to actually move, but then loops back to being stuck again


Tread mills are bad for your knees. Get a bowflex :stuck_out_tongue_winking_eye:


10 characters


PG still have nothing to say on this issue? I’ve lost out on daily tokens because of this. And shortly will miss out on the daily card game … I mean I really need the 1.2k earth shards. But seriously, I get there’s a backlog in tickets with the banning but how about helping the people out that are still giving you money rather than the people who cheated you out of it?

Meh, I was gonna delete that as it sounds harsh, but the point kinda stands.


We have had someone from Dreadnaughts “delayed” at one of our castles for <1min for two days now.

We have three “ghost” primarchs delayed at a castle for which they have free passage. When you click on them, you get no radial menu, just the white circle, so you cannot identify them. If you click manage for the castle, they are not listed as even being there.


Same here. Most of my team has one or both primarchs stuck in a loop.


Has anyone tried dropping the shield or resetting safe passage?


I’ve heard if you quit your team, get ur prime wiped out, then rejoins your team it resets everything and you can re spawn the prime with no issues. I’ll try this when my officers get on.


I have removed and readded free passage, but that did not resolve the problem…


Atlas is still glitched in a big way, going on day 2 of this. Ever since the upkeep change.
Please let us know what the status on a fix!
Thanks :pray:


@PGDave @PGEggToken

Can we get an update on this?
I’m currently missing yesterday’s card bizarre, today’s eggtokens, collecting my atlas event rewards, and can’t move…


Hi! This is my first post as employee in the forum. I’ve been working in atlas for the last year, and work closely together with pgDave (literally, as my seat is in front of him).

I am the person who is responsible for this supposed “improvement”, but as we all know, there was a bump here and there. I take all the blame.


We know it’s an issue, we are trying our best to fix it. We thought we fixed it, but we might be wrong. If you think you encounter an issue related to primarch movement (including primarch level 0) please help us by giving this information:

  • Your current primarch Region / Castle location name.
  • The time estimation it happened (± 10mins).

Things you can try:

  • Move now to nearby castle. It might stop your continuous movement / waypoint still exists.

We are still trying to figure out about black loading screen with the atlas event page.

Longer Version with a bit Technical Detail

I would like to share the details of what happening for the last two days, since the changes went live. The idea of the changes is to improve performance on a castle / region that is very busy, especially when a “war” happening. People who have been in a war often experience the frustration that they can’t go to on / off the war because the Move Now action failing most of the time.

The improvement will require very big changes in the core of Atlas system, and it’ll require more than one step. The primarch movement is the first one, the next would be battle, and so on and so on.

Back to topic. It’s very hard to test scalability, especially when it’s working ok in our test environment. And a lot of cases shows up only in production.

Day 1

The system goes live at 10am Jan 9 PST. This is what happened:

All the regions processing get delayed up to 20 minutes (!!). We were able to fix that (or at least, reducing the effect). It continues for the rest of the day, but it’s not as worse as the beginning.

We decided to call it a day when the average worst case is 5 minutes to process the movement.

Day 2

The firefight continued. We got more data and information from the log that we put before we go to bed. All the days is between putting more log and trying a fix. The core issues fixed when eggtoken post the fix went live.

But apparently it still not addressing all issue.

Day 3

Some region still get affected and delayed for 30 minutes. I think w found and fix the cause for that particular issue, and I think we fixed all the remaining problem. My reason is because of for the last hour, the average worst case is consistent at 4s - 5s.


Based on our data, we thought we solved the problem. But we definitely heard you! If you think you still encounter the problem, and it doesn’t fix it self in 1 minute, please give us this information:

  • The region you found the inconsistency (or the castle name, or the coordinate)
  • The timerange it’s happening

Your help will be really helpful to us to investigate existing problem. As we are currently quite blind because our monitor system doesn’t shows anything bad.

Thank you!


My Current location and Prim @pgDin I’ll give you my log in and password if you’d like :woman_shrugging::smile: My Prim isn’t traveling to far to get home


Top pic is me trying to look into any menu(including trying to collect my egg tokens and event items)

Bottom pic is me trying to move, shows a delay me move then jump back to old position


X: 415 ; Y: -124,4

we and other teams are stucking there… even if it looks like i move my rusher away, it gets resetted and be again on such position…

it really disturb the whole game, there is for sure a huge error.
Thank you for taking responsibility, i am happy someone is honest about and detailed :slight_smile:


It started yesterday morning for myself at 8:00 AM CST for me. I had logged in earlier and was able to collect tokens from Atlas yesterday morning. At 8 AM I relogged back in and moved my Prim, it got stuck in a loop and ever since then “all” the Atlas screens are black with loading messages.


Hey there,

Black loadingscreen whenever i try to manage anything. I cant donate troops, gold or simple click a fort.

My prim seems to travel on a path south, gets 5here and starts over. This repeats again and again.

The issue started yesterday, I am uncertain about a precise hour…



We have a guess for black webview, are those who encounter black screen playing android and updates to the latest version?
@Nuffle @HaileyBears @iDREAMiKILLERi