Primarchs "delayed" at bases


iOS is what I’m playing on

iOS 11.2.2


This was an issue on 6.0, but it went away later in the day (earlier this week but don’t remember when). I’ll poke someone I think is on the latest version. iOS is also seeing the error, though.

Edit: confirmed not an issue on 8.1.0
Edit 2: This is in regards to the black screen.


IOS for myself


Easy way for you guys to see whose is stuck. Pretty much every NML around me has tons of primarchs which as just sitting at the NML base islands. More then likely all of them are stuck. It seems that if you moved your primarch when the glitch was active it’s still broken. My second primarch I did not touch until today and it works just fine. My primarch is stuck in the NML next to Aeven.


Thank you for the lengthy and pretty graph analysis of what is wrong.(honestly wouldn’t that time have been better spent fixing the issue???.. Just an opinion from this remaining player)

But really, How many times do we have to say “it’s broken”??

I have tried everything and my Primarchs are stuck in an endless loop. I asked PG to move my Primarchs to HOME base, after a day still no correction.

We lose all around and we can’t even get a response from support but have to keep logging into the forums(yes that is still broken too) to get a status and yet the answer is as vague as the resolution.

We “think it’s fixed” is akin to “we really don’t know what we screwed up”

How about a timeframe? The Atlas event is all but useless right now as I can’t use Primarchs to get GP in order to upgrade in order to get points. Primarchs can’t get to poachers in other areas and I’m out of targets.


Please submit a ticket and join the queue…


Hi Din,
Prime stuck at -43,11 coordinates. Also, second prime disappeared. Occurred about 38 hrs ago.

Tried all the things support have suggested and they didn’t fix.

Kind regards,



Garoperam ,castle vallalala stuck dealy 1min
Try your sol, but it didn’t work.

And can’t access atlas page like event page, castle details, daily tokens.


Still broken and sent in screenshots


Well then. Lots of action since last night when I initially posted it during my gold farming lol.

I’m on Android 8.1.0 on my Google pixel.
I can access absolutely everything normally except my primarch is running around like a drunken cat who has had just a wee bit too much catnip. This doesn’t allow me to transfer any troops since he won’t sit still for ANY duration of time. He is currently teleporting back to the land pictures below. 🤷


Collecting egg tokens

trying to manage the islands

trying to access the event

My stuck prims


Same with me. One primArch stuck. Tried deleting reinstalling. Nothing. Using latest iOS. Can’t get into any manage screens. Stuck at slomalos -0


A fix has been deployed as of 11 minutes ago (roughly 9:19pm PT). Thanks to everyone who provided information and screenshots here. And a special thanks to @WintersHere and his team for letting us login into to his account and helping us get to the bottom of the issue. Primarchs should once again follow orders, and the endless supply of black screens should now be gone so you can collect event prizes, view continent details, etc.


Thank you @PGDave and @pgDin, can confirm that issue is fixed for me


Oh thank God. Mine is fixed too :joy:


Thank you @PGDave and @pgDin it’s working for me!! :hugs:


Yep seems to be working for me , even though I have missed out of 1 card game


Anytime, Thank you with the quick response on the matter. I just hope I don’t get banned for Account sharing with PG @PGDave lol.


Thank you so very much! Prims are home. I can access the event and collect my egg tokens. Unfortunately, I still can’t access island management pages. Is a fix coming for that as well? Or should I try reinstalling again?


Sorted! YAY! Thank you so very much.