Problem with claiming prizes


i spend around 1,500 + / - egg tokens and it did nothing. i spouse to have 1.044 points but it shows 1.0 k witch are the points required to claim the prizes and yet it still says 6 points to go(on my second account) .Does anyone have the same problem ??
There are any solutions???
Thanks for your support. Regards ZuZu99

Try to close and hard quit your game and re-log in. I had a few minutes of lag on my account at the start of the event.

1 Like

i tried that many times and i updated my game too …but it didn’t change!

Hey ZuZu!

Yeah, it’s possible the update to you going over the 1k points hasn’t totally finished updating on our servers. If you’re continuing to experience this in the next day or so, please submit a ticket to our support team so they can escalate as necessary!

1 Like

Is it possible that the actual prize tier is 1.05K points, as that would coincide with the total you listed (1044). 6 more points to reach prize tier, as well as the points required for the next tier. 356 to reach 1.4K prize.

1 Like

thank you :blush:
i tried something else to see if the “bug” goes but nothing changed, i’ll attach a picture.
thank you again :blush::rose:

Also the 1k award is a bit nasty in breeding, since it’s actually set at 1050 points but rounded in the display. Or at least it used to be, maybe they fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.