Sync Error When Loading The Game

Everytime I try to start up the game it loads for a while, then I get an error saying War Dragons is trying to sync with the servers and the game restarts and it repeats. I don’t really want to start a new game, is there something I can do to fix this?

Tried uninstalling? Make sure u don’t use the account on two devices.

Yeah, I’ve tried uninstalling and reinstalling a bunch of times and this is the only device my account should be on.

Use Vpn? Disable it. IS ur device time and date right? Up to date app? If that dosent help, only one way! Send a ticket.

1 Like

No, yes and yes. I guess I’d better do that then! How do I do that?

How to file a ticket in game with support


Following steps

on Android


on iOS

ss3%20ios


Filing a ticket with support using a web browser

You can also contact support from your browser using the following URL:

https://wardragons.zendesk.com/hc/en-us

You will also need to obtain a password in order to be able to log into the site. You can do that by clicking on the “Sign In” link and then select the “Get a password” option.

Please have your Support ID (in game settings > About tab > right at the top) at hand.


You can also access this information if you go to your phone settings, scroll down to the WD app > support ID.

If you’re unable to find your support ID, just use 0000 instead.


Last Resort

If you have tried the above two methods and you still haven’t been successful in submitting a ticket, you can email support here: support@wardragons.zendesk.com

Have a great day!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.