Version 4.30 Release Notes


#145

I’m upgrading my Breeding castle and had 18 days left on it. I’m also doing a research and had 3 days left on it. After I’ve upgraded my game, the timers have reset. I now have 27 days left on my breeding castle and 5 days on my research.

Anyone else with this problem?


#146

Imagine how I felt when my STORAGE upgrade time suddenly increased by 100%, Breeding castle by 150% (Roughly). Plus the research time is now longer than it was when started!!! It was 7 days originally, now 8 left…

I also need to mention, that this upgrade did more damage than the above:

Main game lags. Atlas lags even worse, it was like this during 4.20. When it seemed to be fine with 4.24…

So those who cry about not having access to Atlas, be happy: if you did, it would give you more headache than benefit.


#147

This!
This is biggest issue of all. Jitters and freezes during battle are hateful, when it happens even without backup/defender.


#148

The load time post update is a lot slower than before :see_no_evil: it takes so long to actually see if there are any primarchs out there. Scrolling around the map is a tedious loading process. One day it would be nice to have this load quick enough to make it worthwhile spending more time in Atlas


#149

what happened to that? :flushed:


#150

Just downloaded the 4.30 update. The Springveil map is gone. Was this intended?


#151

Lot of problems appear after the release this morning … :weary:


#152

it loads in seconds here


#153

I speed up my egg token mission buying it out with rubies, and this happen:

Is this bulleted note shouldve prevented the above? Or my understanding is incorrect:

@PGEggToken may I ask clarification regarding this matter?


#154

In the mean time, you can see if havoc or chaos will work for the mission.


#155

I finished storage with timers but now I can’t build anything. I upgrade and within a minute or so get a sync error and it rolls back. I’ve force quit and even reinstalled the game. I tried to put in a ticket but when I go to Help in game it says it can’t connect.

And the egg in my incubator is gold. But that’s insignificant compared to being unable to build. Lol


#156

Yep… In the meantime, gonna wake up one of my dragons who has… :sob:

Edit: used Abrean Chaos… did it twice but the mission still not there…


#157

It is a known issue PG is working on it


#158

@ryathe From what I have seen in this thread the issue being reported is time being added to upgrades in progress before updating. I am reporting a different issue.


#159

I think Autumn’s reap is kind of like vampiric touch as it grants health on building destruction in addition to increasing attack and rage regeneration while active. Maybe try that?


#160

Please try to fix the issue of missing ‘Transfer’ button in the Primarch Menu of each territory as soon as possible.


#162

Can PG release an update without bugs?
I guess No.
I think you are paying for useless QC department…


#163

Autumn reap is the same as full moon, and I think blood fury as well… chaos isn’t the same spell :sweat_smile:


#164

Yesss! Seems fair :smile:


#165

This! Had not noticed this before but the research buffs to reduce time spent on upgrades and research is not present