Version 4.96 Release Notes Official Discussion Thread


#61

The Atlas Packs other than those would be unavailable since Atlas is still down for maintenance. The crafting packs will be available all the time.


#62

Thank you, that explains it. :woman_facepalming:


#63

Atlas PvP will remain disabled until 7:30 pm PT


#64

and when can we go back to atlas? :slight_smile:


#65

Rider reset option… awesome… the cost :face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth: good thing I have no big mistakes to fix…it seems to me f2p that did screw up will now be forced to make hard choices and as someone mentioned it’s a bit odd that you can unequip gear for a reasonable cost but you chose to charge essentially 25 gold chests to reset skills


#66

Like others, I’d rather see the option to remove glyphs and runes from dragons and a lower cost on rubies to remove base runes and glyphs. Rider reset is great, but 10k rubies or diamonds per reset? Forget that! It’s cheaper to get a new rider. Not overwhelmed by this update.


#67

Atlas button is back but still gives error every time?


#68

awesome. updated. get atlas icon back, can’t enter. Probably 20 tries and get in , and now no castles loading. great update once again pg s\


#69

Same failed to load error, several restarts… same for other team members, as of now no one else on my team can get atlas to load.


#70

Can you please, for the love of all things holy, just fix the stability of Atlas? “Failed to set up Atlas” might as well be your new splash screen.

And why is it that when I am IN Atlas, and finish an attack, I have to have Atlas set up again? Wasn’t I just there? When did I leave? Why did I have to leave? Why can’t you people make this thing work? Why do we continue to put up with this sub-par performance? Why do I think complaining will actually change anything?

These and other questions will be answered (or maybe they won’t) when we return to “As the Dragon Turns”


#71

As has been said, even after a billion tries and reboots and can finally get in, no castles will load for me they are all greyed out


#72

We got the Upkeep reminder right before it went off. Now only one of us can get into the castle menu, but

Yes, this is one of those “What the actual Duck?!” moments

Update: after countless tries I got in an paid my dues. But it wasn’t easy.


#73

Coords please :smiling_imp:


#74

I got the same error on first attempt, but second attempt worked… repeated on second castle.


#75

In Atlas now but castles are loading very slow and in many cases not at all. Invader working fine.


#76

Same for me.


#77

What does “support for new dragons and spells” mean?
on the app update info in the appstore for the new version.


#78

For the love of god please fix the invite issue for potential new members. This is driving me absolutely mad. Every time they try accept and get their error message it floods Team Chat with notifications that they have joined. If they press this 1000 times per person we will get the notification in team chat 1000 times per person. I know that is an extreme example but I have seen it max all the chat logs in Team Chat before. Full, regardless of not reaching the 1000 mark!

@Arelyna


#79

Atlas is pretty much unplayable at the moment because of the slooowwww loading. When you do finally get a run in it boots you back to the main game when it’s over.:man_shrugging:


#80

Agree with the above poster. Getting into atlas now involves 5 “failed to setup atlas” messages, then when you get into atlas. Quests, castles, etc take forever to load (or if they don’t load at all, you have to exit atlas, risk more failure to setup atlas messages, and then come back into atlas). I haven’t been able to determine if crashes have been fixed bc it takes so long to get into atlas.