Version 5.05 and Android OS 9

Ok, when I checked for a game update nothing was showing, so out of habit I checked for OS updates. It showed one. I downloaded and installed, then when I checked for a game update it was offered. I updated… Now when I try to start the game it initiates and then disappears. It still shows as an open app, but I cannot get it to actually load and stay open. Is anyone else having this issue?..

My team is gonna kill me :cry:. And of course this happens at the beginning of an event… Not that that matters, middle of event would be as bad I guess

I would try to delete app and restart phone and then download game again and if that doesn’t work make a ticket on the website

Same here for more than 6 days now. Understand your pain

When the game loads, the loading screen shows 50%. As soon as it crosses to 51%, boom, game shuts down. The update did nothing for me actually. No help.

@Arelyna actually tried to fix it, but still nothing positive happened. I don’t know what am I going to do.

Ok, I have cleared cache, and installed and reinstalled, shut down and restarted phone and nothing. I will try uninstall, shut down, reinstall and see if that does anything

@PipBat did that 16 times.
Can say no result here.

I am desperately trying every minute to like clear cache, do something other in phone like no autosave of data, deleting any backups I had for game, but still nothing.
Did the whole uninstall, cache, reboot thing.
I think my phone will revert to dev mode if I do it again in future.

Yeaaah… no joy. Well, at this rate will have no event participation and will fall off team with inactivity, lose egg tokens and daily log in and quest rewards… Oh yeah, and the financial investment I have put into this game … NOT a happy bat :slightly_frowning_face:

What level were you?

I was 81 and in the verge of unlocking gold tier for all of my seasonals. Had bred khrysos too and trained him till lvl4

296, 297 … Somewhere in there… Going to continue to try to play with storage, but I should have plenty available.

How do you send a ticket through the forums?

Donno @PipBat donno but arelyna said that too much ticket will damage our chances

I think this is a huge problem as I have seen many users have the same exact problem like us now.

@moderators how do u send a ticket thru forums

We should probably also start another forum topic like entitled “PG Can we talk 2?”

How to file a ticket in game with support


Following steps

on Android


on iOS

ss3%20ios


Filing a ticket with support using a web browser

You can also contact support from your browser using the following URL:

https://wardragons.zendesk.com/hc/en-us

Please have your Support ID (in game settings > About tab > right at the top) at hand.

You will also need to obtain a password in order to be able to log into the site. You can do that by clicking on the “Sign In” link and then select the “Get a password” option.


Last Resort

If you have tried the above two methods and you still haven’t been successful in submitting a ticket, you can email support here: support@wardragons.zendesk.com

1 Like

Really I have interacted with some who also have the same problems. Then there were some who had these but they left wd. We should organise another PG talk seriously regarding this matter as to why is this happening to us.

@Lutrus what if we don’t know our support I’d?

All we can do is try. PG tends to ignore things like this…A letter from the community

2 Likes