Won't let me open any chests!

Ok why is it that every time there is an update there is always a glitch. I cannot open any chests what so ever. I have reported this to PG multiple times with no resolution I keep being told to restart my app and it should be fine. Well guess what…it is not fine. I have uninstalled and reinstalled the app. I even cleaned my phone cache and memory after doing a restart of phone and still no help. I also did not receive all the gold chest I claimed from the Equestor line they are not all showing up. So there needs to be a resolution to this issue. I cannot open any chests and can’t access timers or anything. PG help…come on with the amount of money I spend in this game this is freaking ridiculous. I can’t even open or purchase any chests cause it says I don’t have the proper currency.

I am pretty sure it is server and or software problems…capacity or synchronization and well the game is buggy as all get out.

That still doesn’t help me.

Have you submitted a support ticket? If restarting the ap does not work this is your best bet. Several players on our team are having the same issue.

With some synchronization issues placing a building in and out of storage will help. This seems to help when changing base layout not sure if it would help with chests.

I’ve had a similar issue with gold chests, I’ve got over 5k in rubies but when I try to buy a 10x pack it gives me the same message. I’ve sent screenshots and filled a ticket, they said they’re working on it but you know how that goes…

Same problem…:rage:

I have the same issue. Opened a ticket last night and support replied quickly that they are working on it


Just adding my 2 cents. (that second picture was a prompt I was given because it showed me at negative 3000 embers)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.